Bedienung

Menü File Menü subModels Menü Options Menü Display Menü Modify Menü Select Menü Group Menü Standards Menü Catalog Menü Application Menü Process Menü Plugin Menü Remote Grafikfunktionen Measure Search / Name Interaction Checkbox Hide, View Checkbox Search/Name Checkbox RotCen Checkbox 3D, Shade Tastaturcodes: ____________________________________________________________________________

Menü File:

New Open Model Insert Import Mockup native save Model (as) compress native Models Print ____________________________________________________________________________

Menü subModels:

Siehe auch MultiModelsupport Siehe auch subModels benutzen (positionieren) Siehe auch Assembly erstellen activate submodel Ein subModel oder das Hauptmodell zur Bearbeiting aktivieren. "--main--" ist das Hauptmodell. Nach dem Erstellen eines Submodell: zurück in das Hauptmodell, weiter mit subModels benutzen move main --> new submodel Alle Objekte im Hauptmodell in ein subModell verschieben. Siehe subModels benutzen create new submodel Ein neues (leeres) subModell erzeugen und zur Bearbeitung aktivieren. save Submodel to File Das momentan aktive subModel in eine Datei ausgeben. Dieses kann normal geladen werden oder als externes subModel genutzt werden. load Submodel from File ein Model wird geladen, aber nicht als Hauptmodell (main), sondern als internes Submodell. Submodellname ist der Dateiname des geladenen Modells. Das Submodell ist noch nicht sichtbar; siehe subModels benutzen rename Submodel Submodel umbenennen. delete Submodel Submodel löschen. modify Position of subModel ____________________________________________________________________________

Menü Options:

compile DLLs wenn EIN: vor dem Laden einer DLL wird diese entladen, neu compiliert, neu gelinkt und wieder geladen. (eine Debug-Funktion). MainToolBar wenn AUS: der Hauptfunktionsbalken oben wird ausgeblendet. MessageToolBar wenn AUS: das Meldungsfenster unten wird ausgeblendet. ScreenCast ON Nur Gtk3, wenn EIN: - es wird das Drücken der Maustasten angezeigt. - es wird das Drücken der Keyboardtasten angezeigt. BrowserWindow OFF wenn AUS: das Browserfenster links wird ausgeblendet. RemoteControl OFF wenn AUS: RemoteControl ist deaktiviert. ____________________________________________________________________________

Menü Display:

ObjNames Darstellung der Namenstexte der Elemente; also zB "P20". Darstellung der Richtung aller Bearbeitungswege durch Richtungspfeile. NC-Text Darstellung der NC-Hilfsfunktionen (als Text) an den jeweiligen Positionen. Dargestellt werden z.B. alle Insert-Texte, STOP, .... PointDisplay OFF Alle Punkte ausblenden. PlanesDisplay OFF Alle Ebenen ausblenden. SolidDisplay OFF Alle Solids ausblenden. ____________________________________________________________________________

Checkbox Hide / View Hide: es werden beliebige graf. Objekte ausgeblendet. View: es werden nur alle momentan ausgeblendeten Elemente angezeigt; selektieren Sie Elemente, die wieder dargestellt werden sollen ____________________________________________________________________________

Menü Modify:

modelPosition Curve->Circ
Linetyp SurfaceStyle SurfaceColor SurfaceTransparenz solid 50% - transparent transparent (voll transparent) SurfaceTexture ObjectNames Siehe Search / Name.
Edit (F3) Die momentan aktive Codezeile mit dem Systemeditor öffnen. APT-Clean (F4) Endgültiges Entfernen aller gelöschten Zeilen. Delete last Obj (Ctrl-Z) Zuletzt erzeugtes Objekt löschen. Restore last deleted (Ctrl-Y) Zuletzt gelöschtes Objekt reaktivieren. ____________________________________________________________________________

Menü Group:

add Obj (remove) Alle nachfolgend selektierten Objekte werden der Gruppe zugefügt. Ein Objekt nochmals selektieren: aus der Gruppe entfernen.

save Group --> File Alle Objekte der Gruppe in eine Datei (format native - .gcad) ausgeben. ____________________________________________________________________________

Checkbox Modify/Delete Selektieren Sie die Checkbox "Modify/Delete" und das geometrische Objekt - oder selektieren Sie das Objekt mit gedrückter Control-Taste; Es wird nun das folgende Menü angezeigt: <<--prv nxt-->> zeigt alle vom selektierten Objekt abhängigen Objekte Modify Obj. Modifizieren / Return-Taste od. rechte-Maustaste Delete Obj. löschen / Lösch-Taste (Entf-Taste) Done beenden / Ctrl-rechte-Maustaste Delete: Es wird das Objekt und alle seine Hilfsobjekte angezeigt. Es muss auch jedes einzelne Hilfsobjekt explizit mit der Lösch-Taste entfernt werden. Zurückholen der gelöschten Objekte mit Taste Ctrl-Y. Beispiel: 1 P20=P(-16.71 -32.4 0) 2 P21=P(-0.83 -22.12 0) 3 P22=P(-2.1 -30.41 0) 4 L20=P20 P21 5 L21=CUT L20 P22 Objekt P20 hat 2 abhängige Objekte: L20, L21. Objekt L21 hat 4 Hilfsobjekte: L20 P20 P21 P2. ____________________________________________________________________________

Checkbox 3D, Shade 3D: AUS: das Modell kann nicht gedreht werden, die Ansichtsebene ist fixiert. Für 2D-Draufsicht: Button "Top", dann "3D" AUS. Shade: AUS: Flächen und Solids werden nur als Drahtmodell dargestellt. EIN: Flächen und Solids werden schattiert dargestellt. ____________________________________________________________________________